FS behindern sich irgendwie gegenseitig?!

  • Hallo zusammen !


    Meine kleine Testanlage besteht folgenden Strecken:
    1 Pendelstrecke mit einer Weiche und 2 Startgleisen auf der einen Seite, einem Bahnhofshalt unterwegs sowie dem Ende der Strecke mit Richtungswechsel. Hier pendeln 2 Triebwagen abwechselnd. Abgehandelt wird dies über 2 mal 4 FS ohne jeglichen Schnickschnack o.ä.
    2 Kreise mit jeweils 3 Blöcken auf denen je 2 Loks ihre Kreise ziehen, auch ohne sonstige Komponenten.


    Der Commander ist auf dem aktuellen Stand, als Besetztmelder verwende ich 5233 Gleisbelegtmelder mit Rückmelder von Viessmann. Gleismaterial ist Trix C-Gleis, gefahren wird DCC.


    Wenn ich nur die Pendelstrecke laufen lasse (Modus Vollautomatisch) ist die Welt in Ordnung. Des Gleichen wenn nur die beiden Kreise betrieben werde.
    Sowohl Pendel- als auch Block-Strecke/n sind mehrere Stunden fehlerfrei gelaufen.


    Pendelzugstrecke und Kreise beeinflußen sich jedoch auf eine irgendwie magische Art, die sich dahingehend äussert, das es auf den Blockstrecken "Auffahrunfälle" gibt (Loks bleiben auf freier Strecke stehen) bzw. ab und an einer der beiden Pendeltriebwagen über den Endprellboch hinausschießt und nicht abschaltet.(bremst)
    Dabei ist es egal ob eine oder beide Kreise in Betrieb sind.


    So, nun meine Bitte:
    Macht mir doch bitte mal Vorschläge, was ich noch kontrollieren kann. Irgendwie bin ich, nachdem ich jetzt schon fast eine Woche alles Mögliche ausprobiert habe, mit meinem "Latein" am Ende.
    Kann es sein, daß es Zeitprobleme beim s88-Bus gibt ? Wäre aber doch unwahrscheinlich, oder ? Die Verkabelung ist ebenso wie die Gleise komplett neu, alles Gleisanschlüsse sind gelötet.


    Trotz alledem bin ich mit dem Commander sehr zufrieden, sehe das hohe Potential was in ihm steckt, aber, als ehemaliger Informatiker, auch die Masse an Problemen, die es noch zu lösen gibt.
    Ich habe für mich speziell zur FS-Problematik mal eine Fehler/Verbesserungsliste erstellt, die ich gerne weitergeben möchte. Wo darf man so etwas eintragen/hinschicken ? Vielleicht könnt Ihr mir auch da mal 'nen Tip geben.


    Vielen Dank schon mal im voraus !


    Klaus

    USA-H0,60er Jahre Ostküste
    Commander-1.052,Lenz LZV100,Arnold Dig.
    Lenz LH90,XPA,LK100,LC100,PC-Windows7
    Lokdek.DCC+MOT fast aller Herst.
    Magnet/Schaltdek.Viessm.,Arnold,ESU,integr.Weichendek.Märklin
    Rückmeld.s88 (V.5233)
    Gleise RocoLine,Trix+Märklin C

  • Hallo Klaus. Mit der Pendelstrecke kenne ich mich nicht aus, aber mit Bahnhof- und Blockbetrieb
    habe ich einige Erfahrung. Wenn Du mir die Fahrstraßenbeschreibungen des Blockbetriebs an comfan@t-online.de mailst, sehe ich diese durch und sage Dir meine Meinung dazu. Ggf. kann
    ich diese auf meine Testanlage testen.

  • Hallo Klaus,


    die Fahrstrassen behindern sich nicht gegenseitig, das Problem ist wahrscheinlich ein Softwarefehler, bei Einsatz von 2 Loks läuft auch bei mir alles Problemlos, sobald jedoch eine Dritte Lok ins Spiel kommt, werden die Loks in den Fahrstrassen auf den Zugnummerfeldern nicht mehr korrekt ab- und angemeldet, wodurch z.B. eine Lok auf einem Block nicht mehr losfährt, da ein zu beachtender Abschnitt zwar frei ist, der Commander dort aber noch eine Lok angemeldet hat, bzw. fährt eine gestartete Lok durch, da der Commander eine falsche Lok für die FS nutzt. Damit fährt sie dann natürlich bis zum Ende.
    Die Darstellung im Gleisplan stimmt ebenfalls dann nicht mehr, es werden Strecken als besetzt markiert die von den Rückmeldern aber als frei signalisiert werden, da die entsprechenden Rückmeldeeingänge grün sind, im Gleisplan aber rot dargestellt sind. Daraus resultieren dann sicher auch die Auffahrunfälle auf Deiner Anlage.
    Die Zugverfolgung erfolgt ja beim Commander nur über die FS, wenn also eine Lok auf einem Startkontakt angemeldet ist, dieser in einer FS aufgerufen wird, dann wird diese Lok von dem Zugnummernfeld abgemeldet und am Zielkontakt wieder angemeldet. Bei manueller Fahrt zeigt der Commander die zuletzt angemeldete Lok an, dies kann von einer FS sein, oder man hat einmal eine Lok auf diesem Feld angemeldet.
    Mit dem derzeitigen Softwarestand ist ein fehlerfreier Automatikbetrieb mit mehreren Loks meiner Meinung nach nicht möglich, eventuell wird es mit einem folgenden Softwareupdate behoben, also Testen und Hoffen.


    Tschüß
    TT-Driver

    Spur TT, Commander SW 1.052, DCC, Rückmelder IEK und LDT, Weichendecoder von Lenz und LDT, Loks von BTTB, Kühn, Tillig, Piko,

  • Hallo TT driver, Hallo Klaus,
    Das ist so nicht richtig, es gibt zwar zugegeben noch einige Bugs in der Software aber das sind nicht die Fehler die Sie beschreiben. Diese Formation des Ablaufs haben wir hier im Hause mehrfach simuliert ohne Probleme.
    Es ist absolut möglich mit mehr als drei Loks ohne Probleme zu fahren und einen einwandfreien Ablauf der Fahrstrassen zu sichern. Klaus hat es ja bewiesen, denn es fahren je zwei Loks in 2 Blockstrecken ohne Probleme. Es gibt auch Anwender im Forum die gleichzeitig 9 Züge fahren haben.
    Erst wenn Klaus die Pendelzugstrecke mit einbindet, gibt es Störungen.
    Also ist doch hier eine Problemlösung zu suchen.
    TT-Driver, Mit Ihrem Beitrag helfen Sie keinem im Forum. Das Problem zu pauschalieren, es geht ja eh nicht, ist nicht OK.
    Ich habe folgende Frage an Klaus.
    Kreuzt die Pendelzugstrecke irgendwo die beiden anderen Strecken ?
    In welcher Karte haben Sie die ZUG ID Stop Befehle eingetragen, epfohlen wird in Karte 5.
    Ist ein Matrix Abgleich, sich ausschließender Fahrstrassen gemacht worden?
    Tipp: dieser sollte erst nach Abschluss aller Fahrstrassen Programmierungen gemacht werden um alle Fstr. zu berücksichtigen.
    Eventuell hilft auch in der Fstr. Karte7 Auflösen eine Zeiteingabe in der eine Fstr. verzögert ausgelöst werden soll.

    Mit freundlichen Grüßen,
    Viessmann Modelltechnik GmbH


    iA Jürgen Meier

  • Hallo Herr Meier,


    wenn C-User mit 9 Zügen im Blockbetrieb fehlerfrei unterwegs sind, wobei in unserer Testreihe nur ein freier Block zwischen den Zügen liegt, so bin ich an deren Programmierung interressiert. Anscheinend gibt es ein reines Zeitproblem mit der Ab- und Anmeldung der Zugnummern im Automatikbetrieb. Auf meiner Anlage sind ebenfalls mehr wie 2 Züge unterwegs, nur 2 im Blockbereich.dann Blockbetrieb o.K., wenn mehr wie 2 dann heilloses Durcheinander. Der Rest ist auf meiner Bergstrecke in Aktion, welche im Fehlerfall der Blockstrecke aber auch in Mitleidenschaft gezogen wird.
    Wurden bei den Tests in Ihrem Haus die Loks mit oder ohne Railcom gefahren, denn ohne Railcom ist die Fehlerhafte Zugnummernzuordnung bei mir nachvollziehbar, wie schon beschrieben werden Blöcke als besetzt markiert, die weder vom Zug besetzt sind, noch vom Rückmelder als besetzt markiert sind. Ich will hier nichts pauschalisieren, aber wenn mehrer C-User über das gleiche Problem diskutieren, dann ist definitiv etwas im nicht in Ordnung.


    Also sollten wir aufhören, über irgendwelche Formgeschichten zu diskutieren, die Probleme müssen gelöst werden, und dabei sollte aber nichts beschönigt werden, denn dass hilft auch niemanden.


    Tschüß
    TT-Driver

    Spur TT, Commander SW 1.052, DCC, Rückmelder IEK und LDT, Weichendecoder von Lenz und LDT, Loks von BTTB, Kühn, Tillig, Piko,

  • Hallo zusammen,


    also bei mir stehen 6 Züge auf der Anlage, und bei mir funktioniert die Automatik.
    Natürlich fahren nicht alle 6 gleichzeitig, aber 2-3 fahren i.d.Regel schon zusammen.
    Fehler treten bei mir nur auf, wenn ich während des Auto-Betrieb den Geisplan wechsle,
    ansonsten läufts im großen und ganzen ziemlich stabil.
    Allerdings fahre ich noch mit 1.021.

    MFG
    Dirk
    _________________________________
    Comander 1.052
    Spur N, Lenz Gold-Mini Lokdecoder

  • Also, die Vergleiche die ich mache, sind immer basierend auf der Software die auch Sie haben. Alles andere währe Unsinn. Es liegt mir nichts daran Fehler zu vertuschen, aber ich kann auch verallgemeinernde Statements nicht akzeptieren die darauf beruhen, es geht mit mehr als 2 Loks nichts. Das ist einfach nicht richtig.
    Dass das ZNR Feld eine problematische Angelegenheit ist, ist bekannt. Wenn man weis dass der Commander hier im Speicher die Zugnummer ablegt und anhand der programmierten Fahrstrassen verfolgt, ist auch klar dass er fehlgeleitet wird, wenn die Fahrstrasse nicht richtig beendet wird. Das kann z.B. sein: Sie entnehmen die Lok vor Ablauf der Fstr. vom Gleis, Sie entgleist, der Zug fährt durch eine falsche Weichenstellung in ein anderes Gleis usw..
    Woher soll der Commander das alles wissen ?.
    Also muss in diesen Fällen zurück gefahren werden, auf das vor dem "Falschen Ereignis "Angezeigte richtige ZNR Feld. Wird das nicht gemacht ist die Zuordnung in den ZNR Feldern passe und Sie haben unstimmige ZNR Meldungen.
    Dieses Problem ist erst gelöst wenn Railcom funktionierend implementiert wurde.
    Wir helfen gerne weiter, was wir brauchen um Fehler den Entwicklern melden zu können ist eine reproduzierbarkeits- Beschreibung. Um diese Fehler beseitigen zu können müssen diese auch simuliert werden können. Beschreibungen die lediglich auf Beobachtungen beruhen und keinen Weg aufzeigen wie dies erreicht wird helfen hier leider nicht weiter.

    Mit freundlichen Grüßen,
    Viessmann Modelltechnik GmbH


    iA Jürgen Meier

  • Hallo Herr Meier,


    bezüglich der Nachvolziehbarkeit der fehlerhaften Fahrstrassen habe ich nochmals getestet und dabei festgestellt, dass bei gleichzeitigem Betrieb von 2 Loks die nacheinander die gleichen FS nutzen alles funktioniert, wobei auch die von den Rückmeldern kommenden Signale korrekt ausgewertet und angezeigt werden.
    Kommt jedoch die Dritte Lok in den Fahrstrassenkreis, werden plötzlich die Rückmeldesignale nicht mehr ausgewertet. Dann fährt z. B. ein Zug nicht mehr los, weil ein Abschnitt im Gleisplan besetzt angezeigt wird, wobei der Rückmeldeeingang grün ist und auch kein Zug auf dem Abschnitt steht. Genauso werden Abschnitte als frei dargestellt, welche aber besetzt sind, auf dem Gleis und auch vom Rückmelder. Was dafür die Ursache ist, kann nur der Programmierer der entsprechenden Software nachvollziehen.
    Um eine fehlerhafte Rückmelde-Datenbank als Ursache zu vermeiden, werde ich die kompletten Rückmeldeeingänge nochmals programmieren.
    Dann werde ich nochmals testen.


    Tschüß
    TT-Driver

    Spur TT, Commander SW 1.052, DCC, Rückmelder IEK und LDT, Weichendecoder von Lenz und LDT, Loks von BTTB, Kühn, Tillig, Piko,

  • Hallo TT Driver,
    Sie können mir gerne auch mal Ihr Backup schicken, dann kann ich mir Ihre Fstr. Programmierung mal ansehen.
    Seltsam ist für mich dass RM Kontakte bei Ihnen frei sind, aber belegt angezeigt werden, und andere die belegt sind als frei gemeldet werden. Wenn es Fehler gibt müssen diese schon einmal in der Rückmeldung gesucht werden. Denn damit kann der Commander natürlich nicht fehlerfrei arbeiten.
    Halten Sie mich bitte auf dem laufenden. Es liegt uns viel daran Fehler oder Missverständnisse zu beseitigen.

    Mit freundlichen Grüßen,
    Viessmann Modelltechnik GmbH


    iA Jürgen Meier

  • Hallo Herr Meier,


    Ich habe vergangene Nacht noch einmal getestet, alle Rückmelder gelöscht, alle neu eingerichtet, (4 Rückmeldeabschnitte im Kreis plus 2 Bahnhofsgleise ) solang nur 2 Loks fahren funktioniert die Zugnummernübergabe korrekt, wenn die Dritte Lok gestartet wird gibt es wieder Fehler. Eine mehrfache Beobachtung und Umschaltung zur Zustandsanzeige zwischen Gleisplan mit Darstellung und den Rückmeldeeingängen im Direktmodus bestärkte meine Vermutung über nicht korrekte Auswertung der Rückmeldungen. Bedauerlicherweise gab es bei diesem Test materielle Schäden, da es zu einer Kollision im nichteinsichtbaren Bereich mit einem Zug kam, welcher laut FS-Steuerung dort gar nicht stehen sollte, laut Rückmelder aber registriert wurde. Daraufhin wurden die Tests abgebrochen. Ich werde ein Backup der Zustände machen, welches ich Ihnen schicke.
    Bitte teilen sie mir dazu Ihre Adresse mit.


    Tschüß
    TT-Driver

    Spur TT, Commander SW 1.052, DCC, Rückmelder IEK und LDT, Weichendecoder von Lenz und LDT, Loks von BTTB, Kühn, Tillig, Piko,


  • Hallo Herr Meier !
    Bitte entschuldigen Sie die späte Antwort, aber ich habe erstmal eine familiäre Osterpause beim Commander eingelegt. Heute ging es dann mit "voller Kraft" weiter.
    Nochmal zur Konstellation:
    - 2 Viessmann s88 Gleisbesetzt/Rückmelder 5233
    - eine DCC Trix C-Gleis Pendelstrecke mit Wechselbetrieb durch 1 Weiche; 1 Zwischenhalt in beide Fahrtrichtungen und eine Endstelle mit Fahrtrichtungswechsel.
    - eine Motorola/DCC Märklin C-Gleis Ringstrecke mit 3 Bahnhofsgleisen, aus denen immer abwechselnd je ein Zug in entgegengesetzte Richtung (2xlinks,1xrechts herum) auf die Reise geschickt wird; je Fahrtrichtung ist ein Zwischenhalt vorgesehen.
    - eine DCC Trix C-Gleis Ringstrecke im Uhrzeigersinn, 3 Blöcke mit 2 Loks im Betrieb.
    - eine DCC Trix C-Gleis Ringstrecke gegen den Uhrzeigersinn, 3 Blöcke mit 2 Loks im Betrieb.
    Keine Strecke hat eine Berührung/Kreuzung mit den Anderen.

    Ich habe wie Sie empfohlen haben alle Fahrstrassen dahingehend verändert, daß im FS Editor Karte 5/8 Schalten mit Angabe des Ziel-Rückmelders die "ZugID WStop" Befehle gegeben werden. (d.h. der Ziel-RM steht nun in 5/8 Schalten und 6/8 Ziel.) Die Karte 7/8 Auflösen beinhaltet jetzt keine Fahrbefehle mehr. Es wurden keine weiteren Verzögerungen zur Lösung des o.g. Problems eingetragen.
    DIe FS Sicherungseingaben (Matrix) werden bei mir schon seit jeher erst am Ende aller FS-Erfassungen/Änderungen gemacht. Vorschlag: Warum wird da nicht ein deutlicher Bildschirm-Hinweis eingeblendet, wo dieses Thema doch so existenziell für die korrekte FS-Funktion ist ??
    So und nun zum Erfreulichen:
    Die FS funktionieren wie gewünscht, d.h. ich habe bis zu 6 Loks gleichzeitig im Betrieb d.h. insgesamt 9 in der Kontrolle der Fahrstrassen.
    Vielen Dank für die entsprechenden Hinweise. Vielleicht sollten Sie bei der nächsten Handbuchüberarbeitung diese Erkenntnisse mal mit einarbeiten.
    2 Merkwürdigkeiten bleiben da noch:
    1) Es gibt, wenn alles läuft, wohl ganz offensichtlich Durchsatzprobleme; d.h. die Strecken laufen für sich allein alle zügig und flott durch, wenn jedoch die Gesamtsteuerung aktiviert wird, bleibt die 1 oder andere Lok im Block auch wohl trotz freier Strecke schon mal länger stehen oder Fahrstrassen werden erst verspätet freigeschaltet. Es wird jedoch immer alles komplett und korrekt abgearbeitet, halt nur mit Zeitverzug. Ich vermute mal, daß das jetzt am s88-Bus liegt, oder ? Da ich mir die Viessmann 5233 gerade neu zusammen mit dem Commander gekauft habe (ich wollte ein getestes, gut eingeführtes System zu meinem Start mit dem Commander), werde ich wohl noch eine Zeit so weiterfahren müssen. Gibt es da Empfehlungen, welchen RM-Bus ich in Zukunft nehmen sollte ? Die jetzt hinterlegten FS sind erst der Anfang und werden nochmal um die gleiche Anzahl plus manuellem Fahrbetrieb ergänzt, d.h. es sollen in der Endausbaustufe ca. 20 Loks vom Commander über FS verwaltet und gesteuert werden. Für einen Tipp wäre ich sehr dankbar.
    2) Im FS Editor Karte 7/8 Auflösen muß in der ersten Erfassungszeile immer ein Eintrag stehen, sonst wird die FS nicht aufgelöst und nichts geht/Loks bleiben einfach stehen. Ich hab, nachdem mich die Sucherei nach dem Fehler fast einen ganzen Tag gekostet hat, mir damit beholfen, daß ich in die erste Erfassungszeile die Freimeldung des entsprechenden Start-Rückmelders (RM xx = grau) der FS eingetragen habe. Und siehe da, auf einmal lief alles wie von Geisterhand.


    Soweit die aktuellen, guten Nachrichten aus dem Erzgebirge,
    Danke und beste Grüße
    Klaus Hohmann


    P.S. Meine sonstigen Fehlermeldungen und Verbesserungsvorschläge habe ich, immer wieder aktualisiert, im Thema "Verbesserungswünsche" eingetragen.

    USA-H0,60er Jahre Ostküste
    Commander-1.052,Lenz LZV100,Arnold Dig.
    Lenz LH90,XPA,LK100,LC100,PC-Windows7
    Lokdek.DCC+MOT fast aller Herst.
    Magnet/Schaltdek.Viessm.,Arnold,ESU,integr.Weichendek.Märklin
    Rückmeld.s88 (V.5233)
    Gleise RocoLine,Trix+Märklin C

  • Hallo zusammen !


    Nachdem ich nun einen ganzen Tag weiter getestet habe, kann ich eigendlich nur Gutes vermelden; die Fahrstrassen-Steuerung ist stabil, so wie ich sie in meinem Eintrag von Gestern beschrieben habe.
    Ein kleines Problem ist da doch noch aufgetreten, von dem ich gerne die Commander-Gemeinde in Kenntnis setzen möchte (und was mich 3 Stunden Suche gekostet hat):


    Ich fahre ja auf Märklin und Trix-C-Gleis und habe die Rückmelde-Strecken dadurch isoliert, daß ich die Kontaktlaschen im Gleis an der Trennstelle komplett entfernt habe; ich hätte es auch mit den Isolierkeilchen von Märklin machen können, war mir aber zu teuer.
    Meine Rückmeldeabschnitte überwache ich nach dem Stromfühlerkonzept mit dem kombinierten Besetz- und Rückmelder 5233 von Viessmann über den s88 Bus.


    Nachdem ich die beiden Blockstrecken-Ovale ausgiebig mit Sololoks getestet hatte, habe ich dann die Wagen der Züge der geplanten Automatikstrecken angekuppelt und die Automatik des Commanders gestartet. Tja, und dann ging auf einmal nach kurzer Zeit garnichts mehr; Loks blieben einfach auf freier Strecke stehen, obwohl die Blockstrecke für sie freigeschaltet war. Der Commander war aber nicht verwirrt o.ä.; nach Umstellung auf Handbetrieb und dem Anhalten der Loks ließ er sich erneut im Automatik-Modus starten (ohne FS-Reset) und alles lief normal weiter, bis zum nächsten außerplanmässigen Stop.


    Nach etwas längerem Grübeln kam mir dann die Idee:
    Einige der eingesetzten 4-achsigen Wagen (ich fahre nach US-Vorbild) hatten Metallradsätze und obwohl sie isoliert sind, keine Beleuchtung oder Widerstände eingebaut sind, reicht das Überfahren der Trennstellen aus, um die Rückmeldung über den s88-Bus binnen kürzester Zeit zu verwirren. Ein Test mit Wagen mit Kunststoffradsätzen brachte den Beweis.

    Also Vorsicht: s88-Bus, Rückmeldung über Stromfühler und die Fahrstrassen des Commander vertragen sich nicht mit Metallradsätzen der Wagen !


    Ich bin jetzt mit der FS-Funktionalität des Commander sehr zufrieden. Danke liebe Viessmänner !
    So, das wars für heute, bis bald
    Klaus


    P.S. Wen die Lösung der FS interessiert möge mir eine email schreiben; ich kann ihm dann eine Excel-Datei mit der Fahrstrassen und ein JPG-Bild des Gleisplanes lt.WinRail zukommen lassen.

    USA-H0,60er Jahre Ostküste
    Commander-1.052,Lenz LZV100,Arnold Dig.
    Lenz LH90,XPA,LK100,LC100,PC-Windows7
    Lokdek.DCC+MOT fast aller Herst.
    Magnet/Schaltdek.Viessm.,Arnold,ESU,integr.Weichendek.Märklin
    Rückmeld.s88 (V.5233)
    Gleise RocoLine,Trix+Märklin C

  • Hallo Klaus,


    bitte chicke mir die Excel Datei und das Bild des Gleisplans an:
    edgar-haeberl@t-online.de


    Gruß
    Eddie

    Spur N, zweigleisige Hauptstrecke (Hundeknochen), eingleisige Nebenstrecke, ca 25 Züge Epoche IV, Fahrbetrieb Automatik funktioniert, Lenz Gold mini und Silver+ Decoder,ESU Decoder, 8x Viessmann 5233,
    Commander 1.402 seit Dez. 2007, Windows Vista