V1.052 s88-5 Contact. Programm bug in resetting occupancy.

  • Hello.


    I use s88 contacts for occupancy information
    I Tested: Viesmann 5233, 5217 and Marklin ruckmelders.
    Block section Current Detectors with optocoupler's isolation and LED indication were preliminary installed and connected to corresponding s88 ruckmelder's contacts. (as alternative - i used also Viessmann 5233 - no change of error)
    Therefore I detect presence of loco without MEM trigging function of Commander using information about current supplied by loco.

    Example: Loco on way - RED. Loco removed - no signal.

    For test i use 12 block sections at my layout connected via current detectors to 12 channels of s88 and 5 DCC locos which can be moved in different combinations in manual mode without any authomation and routing.

    I created appropriate diagramm in Commander.


    During motion: All channels works properly, but 5'th contact(Commander's number- corresponding to s88 ruckmelder's number) rarely(probability =1/3) does not resetted when Loco leave this block section. This bug occurs only with combinations of moving other locomotives at other block sections. In this case Hardware LED of current detector(attached to s88 ruckmelder) resetted with guarantee! But Commanders indication does not resetted even if i ll disconnect 5'th contact by my hand! (i tested different ruckmelders - the same error occurs with each type)


    -If i use single loco on layout - all blocks, including 5'th - work properly.

    -If i connect 5'th block section current detector contact to any other s88 free channel and correspondently renumerate it in diagramm - all works properly with multiple locos in any combination.
    (therefore i suggest that 5'th channel of current detector works properly)

    -If i connect any contact of current detector (corresponding to different occupancy block section) to 5-th channel of s88 ruckmelder (of any type, Viessmann, Marklin), which is correspondently renumerated at Commander's diagramm before testing - above mentioned error occurs again.
    (Therefore i can believe that it was 5'th contact with the side of s88 and Commander is guilty for this error)

    If i change type of ruckmelder or change cable onto more short one - the same error also occurs.
    (Therefore i believe that there are no malfunclion in s88 ruckmelders)

    I DID:
    I cleared all diagramm from Commander exept my own.
    I cleared all device data which is not used.
    I cleared all routes (now i dont use routes in this test. )
    I deleted all non-used locos. (all 5 which are presented - DCC locos )
    I carefully check my diagramm, and then cleared and draw it again, carefully checking all occupancy informations and contact placement on diagram, avoiding any interference.

    In every cases 5'th contact - dont work and error occurs again.

    As i believe , this error can occur due to interference of data in Commander's programm, when multiple loco are used.
    I think so, because i dont detect any hardware dependance of this error.

    Please write me who encounter with it.
    Please tell me about other numbers of bad working contacts.
    Please tell me how to remove this error.


  • At last: My SOLUTION:

    After long testing, i marked that this above mentioned errorneous behaviour in occupancy indication occured in case when error message "corrupt data" preliminary appeared at Commander's start.

    As i detected:
    In aim to remove this above-disscussed errorneous behaviour, it's worth to do the following:
    -Re-save (without changing) all system data again.
    -Restart Commander, and reach disappearing of this red message at start.

    Sometimes, at next start, this red message can appear again, without any reason.
    (I did not change system settings.... or , even i didnt change anything!)
    Simply save and restart it again.

    To work CORRECTLY : Lets start Commander without red messages.
    This can be achieved by re-saving again all system settings and restarting again.
    Dont work with Commander if red message appeared at start!
    You can get a lot of head-pain!

    I think that in case when red message occurs - s88 not fully initialized due to interrupt.
    Therefore this error occurs.
    More precisely:
    I think that red message probably can occur at next start after changing occupancy information which can someway affect on system settings, and Commander errorneously can suppose this side affection as error, although there are no error in system settings, but due to this interrupt - s88 probably has not so full initialisation and works non-correctly.


  • Thanks for posting this. I have had the corrupt data message appear at times when booting Commander, and I could not attribute to anything. I will see if I can make it disappear as you did.

  • Hallo,

    this is a security question.
    There may be an error, most time it isn`t.
    But perhaps there will be an error and therefore you must see for it.

    Viel Grüße
    Dieter Riethenauer

    Commander 1.402, seit 12.07, Fleischm.profigleise N
    Viessmann u. Uhlenbrock Schalt/Magnetartikeldekoder
    Rocco RM 10787 am LSB hinter Viessmann BM 5206,
    Viessmann Booster ECO4, Win 10- 64bit

  • Thanks Vadim, a good suggestion that I had overlooked.

    However, be sure to have the latest update 1.052. Since this update, I have the red error message at startup only very rarely (say 1/30 times).

  • Quote from pierre.bln

    Thanks Vadim, a good suggestion that I had overlooked.

    However, be sure to have the latest update 1.052. Since this update, I have the red error message at startup only very rarely (say 1/30 times).


    My observations:
    These RED ERROR message at StartUp usually occurs after i reprogrammed (for ex.:small changes, like changing name of route) some routes and restart.

    If i ll continue working without additional restart - behaviour of usually good worked routes becomes "so strange"! For example LocoSNorn or LocoSmini commands(Keep direction) can reverse the locomotive, and some routes locked in matrix can be launched simultaneously.
    Therefore one can make a
    CONCLUSION: that these red message, occured during Commander's start probably interrupts initialisation process, and some important initialisations are cancelled. Therefore we can observe so strange behaviour in this case.

    THEREFORE there are SOLUTION: I restarted Commander again and works only if Commander starts normally without any messages.



    V052 has slow screen refresh of diagramm when it works in automatic mode.
    Some contacts can be imagined as busy, but route program knows real status more clearly, and seems as working correctly.
    Yellow routes also has bad refresh. Many of old pieces which must be removed at cancellation remains in diagramm.

    MY WISH: please improve refresh of screen in this situation.