Probleme bei Lichtsignal Programmierung

  • Hallo,


    ich habe mir nun auch den Commander zugelegt und habe auch schon ein paar Fragen:


    Kann ich immer jeweils die nächtliegende Adresse für ein Lichtsignal benutzen wie z.B. Adresse 99 für ein Lichtsignal dann Adresse 98 für ein Lichtsignal usw. So habe ich nämlich jetzt ein paar Signale programmiert aber leider schaltet immer das nächstgelegende Signal mit um. Das dürfte doch eigentlich nicht sein. Beim Programmieren der einzelnen Lichtsignaldecodern war immer nur einer im Programmiermodus.


    Bei mir verschwinden auch öfters auf dem Gleisbildstellpult die Signalsymbole. Ist das ein Bug oder stimmt mit meinem Gerät etwas nicht?


    Wie komme ich an ein Lichtvorsignal dran? Im mitgelieferten Referenzhandbuch ist auf der letzten Seite ein Ausfahrsignal mit Vorsignal abgebildet im Commander selbst ist aber kein solches Symbol zu finden.


    Gibt es ein Gleissymbol für eine Kreuzungsweiche mit einem Antrieb oder muss ich zwei normale Weichensysmbole benutzen?


    Ich wäre sehr dankbar wenn mir jemand die ein oder andere Frage beantworten würde. Die Firmware ist übrigens 1.052.


    Besten Dank.


    Oliver

    Commander FW: 1.052 / DCC
    Spur HO Gleichstrom / Fleischmann PROFI-Gleis
    ROCO Multimaus
    Signal-, Schalt- und Weichendecoder von Digital-Bahn.de
    S88-Rückmeldebausteine von TAMS

  • Hallo Oliver,


    herzlich willkommen als commander-fan.
    Du hast mit Sicherheit eine gute Wahl getroffen.


    Um die jedoch helffen zu können solltest du uns etwas mehr über die echnik deiner Anlage in diesem
    Fall besonders über die Art/Fabrikat/Modell deiner Signale und über deren Ansteuerung/Decoder verraten.
    Im allgemeinen benötigen 2begiffige Signale 1 Adresse und mehrbegriffige 2 Adressen.
    Bei Viessmann gibt es auch spezielle Lichtsignaldecoder, die das automatisch erledigen.
    Aber das sollten wir für eine Antwort wissen.


    Kreuzungsweichen müssen noch zusammengesetz werden.


    Dass die Symbole im Gleisbild verschwinden habe ich noch nicht erlebt. Erscheinen die dann
    wieder von alleine? Da muss jemand anders antworten, oder du musst beim Service anfragen.


    Ich weiß nicht welche Ausgabe des Referenzhandbuches beilegt, 1.1. ist aktuell. Aber sie doch mal auf der homepage
    von Viessmann nach, vielleicht ist dort ein neueres.
    Für das Signalbild ist der Typ also Ausfahrtsignal, Blocksignal usw. wichtig.

    Viel Grüße
    Dieter Riethenauer


    Commander 1.402, seit 12.07, Fleischm.profigleise N
    Viessmann u. Uhlenbrock Schalt/Magnetartikeldekoder
    Rocco RM 10787 am LSB hinter Viessmann BM 5206,
    Viessmann Booster ECO4, Win 10- 64bit

  • Hallo Dieter,


    Danke für die Antwort. Als Fan bezeichne ich mich bis jetzt noch nicht, bin eher am resignieren.


    Die Signale selbst habe ich als Bausatz bei SMDV gekauft (wie den Commander auch), ich denke es sind die von Viessmann nur eben als Bausatz (wird hier glaub ich so nicht angeboten) sehen zumindest genau so aus. Beim Decoder fängt es dann an, ich habe die Decoder selbst bzw. nachgebaut von der Internet-Seite "Digital-Bahn" und dort bei Lichtsignale den normalen Ausfahsignaldecoder der eigentlich alle Signalbilder erzeugen kann. Den Prozessor habe ich als DCC Variante programmiert. Vielleicht programmiere ich sie mal als Motorola Variante.


    Hier mal ein Link zu meinem Stellwerk: http://www.bilder-hochladen.net/files/f4o9-2-jpg-rc.html


    dort kannst du sehen das der Cursor auf einer freien Fläche steht, aber er zeigt oben die Signalsymbol-Auswahl an. Wähle ich nun das darunter liegende Signal-Symbol im Stellwerk an und tippe auf ein oben eingeblendetes Signal-Symbol würde das Signal im Stellwerk wieder erscheinen (Ist schwierig zu beschreiben). Auch wenn die Decoder nicht in Ordnung wären müssten doch die Signalsymbole im Stellwerk die Anzeige übernehmen wie ich oben das jeweilige Signal-Symbol antippe oder sehe ich das falsch? Das tut es bei mir nämlich nicht.


    Mein Referenzhandbuch hat die Version 0.3 (lach), aber auch im neusten 1.1er gibt es das Ausfahrsignal mit Vorsignal.


    Hier mal ein Link zu meinem Gleisbild-Editor: http://www.bilder-hochladen.net/files/f4o9-1-jpg.html


    Oben sieht man alle mir zur Verfügung stehenden Signale. Sieht das bei dir genau so aus? Welches nimmst du für das Vorsignal?


    Keine Ahnung ob ich was falsch mache oder ob das Gerät spinnt?


    Freundliche Grüße aus Köln
    Oliver

    Commander FW: 1.052 / DCC
    Spur HO Gleichstrom / Fleischmann PROFI-Gleis
    ROCO Multimaus
    Signal-, Schalt- und Weichendecoder von Digital-Bahn.de
    S88-Rückmeldebausteine von TAMS

  • Hallo Oliver,


    ein Lichtvorsignal ist in dieser Version 1.052 noch nicht vorhanden. Die Signalauswahl im meinem Gleisplaneditor sieht genauso aus wie deines.


    Wenn deine Lichsignale auf unterschiedliche Adresse reagieren kann es an zwei Möglichkeiten liegen:
    - Dein Decoder kann auf zwei unterschiedliche Adressen programiert werden. Oder
    - Dein Decoder benötigt zur Anzeige des Signlabildes zwei Adressen.
    Auch wenn Du nur eine Adresse programierst (z.B. 98), dann wird die zweite benötigte Adresse automatisch auf die nächst höhere Adresse (z.B: 99) mit programiert.


    Vorschlag: Programmiere ein Lichtsignal auf die Adresse 98 (98 und 99 sind dann belegt) und das zweite Lichsignal auf die Adresse 96 (96 und 97) ist dann belegt. Dann sollten sich bei der Signalbildsteuerung keine überschneidungen mehr geben. Zumindest kenne ich kein Signalbilddecoder mit 3 Adressen.


    Bzgl. das Problem mit verschwundenen Signalen im Gleisbild am Commander ist mir noch nich tüber den Weg gelaufen.
    Hast Du auch im Editor die Signale einzeln gespeichert, oder erst als gesamtes zum Schluß? Ich gehe mal davon aus Du hast zumindest gespeichert? Oder? Haben alle Signale Ihre Adressen erhalten?

  • Hallo Oliver,


    wenn der Decoder nicht richtig arbeitet, bzw. für die Erzeugung der Signalbildern nicht geeignt ist, werden die
    Schaltbilder nicht richtig übertragen.


    Wenn ich es richtig deute hast du Blocksignale und Gleissperrsignale angelegt.
    Die machen nur rot oder grün.


    Sonst kenne ich deine Modelle und deren Funktionsweise nicht.

    Viel Grüße
    Dieter Riethenauer


    Commander 1.402, seit 12.07, Fleischm.profigleise N
    Viessmann u. Uhlenbrock Schalt/Magnetartikeldekoder
    Rocco RM 10787 am LSB hinter Viessmann BM 5206,
    Viessmann Booster ECO4, Win 10- 64bit

  • Hallo Oliver,
    bei selbst gebauten Signalen und Decodern ist das natürlich so eine Sache.
    Bevor Sie die Teile als Signal im Gleisplan eingeben, können Sie jede Adresse Ihres Decoder im Direktmodus Ihres Commanders testen. Dort wird über rot/grün jede einzelne Adresse geschaltet. Wenn Ihr Decoder und Signal dort funktioniert können Sie es auch im Gleisbild anlegen. Funktioniert es im Direktmodus nicht , ist etwas an Ihren Teilen falsch oder defekt.
    Der Commander hat im Direktmodus keine mögliche Fehlerquelle. Denken Sie daran dass alle Decoder mit 4 Ausgängen in vierer Gruppen programmiert werden müssen.
    1-4; 5-8; 9-12 etc. Bei Einzeldecoder ist das oft so wie oben beschrieben, dass grundsätzlich jeder Decoder 2 Digitaladressen reserviert beginnend mit einer ungeraden Adresse. Das ist auch bei unserem Decoder 5224 so.
    Dieser kann dann bis zu 4 Signalbilder zeigen. Dafür braucht man 2 Digitaladressen.
    Das Vorsignal wird es nicht als Symbol im Commander geben.
    Der Commander ist an der Stellwerktechnik der echten Bahn angelehnt die kennen das Vorsignal in der Darstellung auch nicht. Wie der Name schon sagt es ist ein Signal was auf einen Zustand am kommenden Hauptsignal hinweist und ist nur auf der Strecke für den Lokführer wichtig. Elektrisch wird die über das zugehörige Hauptsignal geschalten.
    Bei Viessmann Decodern 5224 wird die auch über mehrere Decoder mit dem Signalbus bewerkstelligt. ( Funktion Vorsignal am Mast, incl. Dunkelschaltung bei rot am Hauptsignal )

    Mit freundlichen Grüßen,
    Viessmann Modelltechnik GmbH


    iA Jürgen Meier

  • Hallo zusammen,


    Herzlichen Dank an Euch alle, es klappt jetzt! ich habe wie vorgeschlagen 4 Decoder mit den Adressen 101, 103, 105 und 107 programmiert und das funktioniert. Jetzt ändert sich nur das angewählte Signal und das Gleisbild zeigt auch die richtige Signalstellung an und ganz wichtig es verschwindet nicht vom Bildschirm. :P


    Am Wochenende geht's dann mit den Rückmeldekontakten weiter :o


    Freundliche Grüße aus Köln
    Oliver

    Commander FW: 1.052 / DCC
    Spur HO Gleichstrom / Fleischmann PROFI-Gleis
    ROCO Multimaus
    Signal-, Schalt- und Weichendecoder von Digital-Bahn.de
    S88-Rückmeldebausteine von TAMS

  • Hallo zusammen,


    brauche wieder Eure Hilfe! Meine Anlage hat keine Trennstellen, nur Reedkontakte. Ist es prinzipiell möglich nur mit Reedkontakten einen Automatikbetrieb hin zu bekommen?


    Ich habe mir mal das Beispiel aus dem Referenzhandbuch mit den 3 Blockstrecken erstellt, bekomme es aber nicht vernünftig zum laufen. Dabei habe ich schon die ersten Probleme mit den Rückmeldern für die Gleisbesetztmeldung die wenn ich es richtig verstanden habe für den Automatikbetrieb zwingend notwendig sind. Da ich nur Reedkontakte (Momentkontakte) habe muß ich ja im Rückmeldeeditor für die jeweiligen Gleisbesetztmelder den MOM-Schalter aktivieren. Im Referenzhandbuch wird zwar gesagt dass man den Rückmeldekontakt im Fahrstrasseneditor zurücksetzen muss, aber leider wird nicht mitgeteilt wo und mit welchen Befehl man den Kontakt wieder zurück setzt. Kann mir da jemand helfen?


    Freundliche Grüße aus Köln
    Oliver

    Commander FW: 1.052 / DCC
    Spur HO Gleichstrom / Fleischmann PROFI-Gleis
    ROCO Multimaus
    Signal-, Schalt- und Weichendecoder von Digital-Bahn.de
    S88-Rückmeldebausteine von TAMS

  • Hallo Oliver,


    ja, es ist möglich den Automatikbetrieb nur mit Reedkontakten zu betreiben. Dem Commander ist es eigentlich egal, welche Kontakte verwendet werden. Ob dies Gleisbelegtmelder oder Radkontakte oder eben REED-Kontakte sind, es gibt immer nur den Zustand 1 oder 0. Dieser Zustand wird im Commander ausgewertet. Wenn auf deiner Anlage eine Trennung nicht möglich ist, so können die REED-Kontakte benutzt werden. Diese müssen, wie DU schon richtig bemerkt hast als Momentkontakt definiert werden. Du kannst in den Rückmeldekontakten den Bereich zwischen 2 Reed-Kont. als Bereich definieren, dann sieht man auch optisch die Belegung. Das Rücksetzen der Momentkontakte erfolgt durch die folgende Fahrstrasse. Hier ein kurzes Beispiel, der Zug hat in FS10 als Zielkontakt den RM25, in der nächsten FS, FS11, welche den Zug vom RM25 wegfährt, muss in den Stellbefehlen der RM25 wieder auf Grau gesetzt werden. Sollte allerdings dein letzter Wagen ebenfalls den Kontakt auslösen, muss noch eine Hilfs-FS programmiert werden. In dieser nutzt du einfach einen weiteren Kontakt als Startkontakt und setzt den Stellbefehl dort. Diese FS enthält keinen Ziel-RM. Dadurch wird sie gestartet und nach Ausführen der Stellbefehle wieder beendet.
    Allerdings bringt das Fehlen von Gleisbelegtmeldern den Nachteil mit sich, dass eine Überwachung von verlorenen Wagen nicht möglich ist.
    Eine spätere Trennung der Gleise ist aber noch möglich, erfordert aber ein bisschen Verdrahtung. Die Trennung geht mit einem Dremel und einer dünnen Trennscheibe recht gut. Anschließend werden die entstandenen Lücken mit 2-Komponenten Harz vergossen und nachgearbeitet. Somit entsteht eine Gleistrennung mit Isolierung. Dies nur mal als Tipp.
    Ich hoffe, ich konnte Dir bei deinem Problem helfen und wünsche viel Spaß beim Probieren.


    Tschüß
    Achim

    Spur TT, Commander SW 1.052, DCC, Rückmelder IEK und LDT, Weichendecoder von Lenz und LDT, Loks von BTTB, Kühn, Tillig, Piko,

  • Hallo Achim,


    Danke für die Antwort, habe es so gemacht wie du geschrieben hast. Funktionierte aber so leider nicht. Ich habe anstatt den Zielkontakt-RM den Startkontakt-RM in die nächste Fahrstraße bei Stellbefehlen eingetragen, den habe ich ja als Momentkontakt definiert (hast du dich vielleicht verschrieben?). Das funktioniert so auch nur wenn ich nun eine zweite Lok benutze (3 Blöcke), sie per Handbetrieb in die entsprechenden Blöcke fahre (Im Direktmodus versichert dass die entsprechenden RM aktiviert sind) und auf Vollautomatik schalte, dann fährt zwar die Lok die in den einzig freien Block fahren kann auch los, aber zur gleichen Zeit wird auch die hintere Lok gelöscht bzw. der RM wird durch abarbeiten der Fahrstrasse der vorderen Lok wohl gelöscht? Ich erwarte eigentlich auch das Rücksetzen des RM-Kontaktes in der gleichen Fahrstrasse bei der Fahrstrasse auflösen Option. Dort ist auch das Symbol aber es hat wohl keine Funktion. Eine Möglichkeit wäre noch wie du sagst eine Hilfs-FS, das wäre aber ein sehr großer Aufwand nur um den RM wieder zu deaktivieren.


    Hast du sonst noch einen Vorschlag?


    Viele Grüße aus Köln
    Oliver

    Commander FW: 1.052 / DCC
    Spur HO Gleichstrom / Fleischmann PROFI-Gleis
    ROCO Multimaus
    Signal-, Schalt- und Weichendecoder von Digital-Bahn.de
    S88-Rückmeldebausteine von TAMS

  • Hallo Oliver,


    nur mal kurz ein Beispiel, die Lok steht auf RM25 und soll zum RM 30 fahren, dann muss in FS1 der Start RM25 auf Rot, die zu beachtenden RM je nach Bedarf + RM30 auf Grau, die Stellbefehle ebenfalls nach Bedarf und der Letzte Stellbefehl RM25 auf Grau, die Schaltgleisfunktionen nach Bedarf, der Ziel RM30, FS auflösen nur den Zughalt, Signale etc.
    Die Rückmelder müssen aber als Momentkontakte definiert und an ein Zugnummernfeld gebunden sein. So funktioniert es, ich habe diese Möglichkeit mit Gleiskontakten getestet.


    Tschüß
    Achim

    Spur TT, Commander SW 1.052, DCC, Rückmelder IEK und LDT, Weichendecoder von Lenz und LDT, Loks von BTTB, Kühn, Tillig, Piko,

  • Hallo Achim,


    Vielen Dank für deine Tips. Jetzt funktioniert es. Muss mir nun mal die einzelnen Fahrstrassen genauer anschauen, denn so richtig hab ich es noch nicht verstanden was da abläuft.


    Freundliche Grüsse aus Köln
    Oliver

    Commander FW: 1.052 / DCC
    Spur HO Gleichstrom / Fleischmann PROFI-Gleis
    ROCO Multimaus
    Signal-, Schalt- und Weichendecoder von Digital-Bahn.de
    S88-Rückmeldebausteine von TAMS

  • Hallo Oliver,


    was da abläuft, ist im Grunde recht einfach. Mit dem Start des Automatikbetriebes werden die Bedingungen für das Auslösen der Fahrstrassen geprüft. Wird eine FS gestartet, sind also alle definierten Bedingungen erfüllt, dann wird die Lok-Nr vom Start-RM angesprochen und der FS zugewiesen. Anscheinend wird die Lok-Nr zwischengespeichert, bis der Ziel-RM erreicht ist. Dort wird die Lok-Nr. dem Ziel-RM wieder zugewiesen. Nach meinen Erfahrungen darf aber keine FS auf einen Ziel-RM (z.B. RM10) zugreifen, solange die FS, welche den RM (RM10) als Start-RM nutzte, nicht abgeschlossen ist.
    Sonst kommen die Lok-Nr im Commander durcheinander, was zu fehlerhaften Steuerbefehlen führt. Ich habe mir einmal ein Flussdiagramm erstellt, wo die anscheinende Funktionsweise dargestellt ist. Das kann ich dir gerne mailen.
    Ich würde mich liebend gerne mal mit einem Programmierer über diese Sachen unterhalten, es würde die Fehlersuche extrem erleichtern.
    Also, viel Spaß noch beim Testen


    Tschüß
    Achim

    Spur TT, Commander SW 1.052, DCC, Rückmelder IEK und LDT, Weichendecoder von Lenz und LDT, Loks von BTTB, Kühn, Tillig, Piko,

  • Hallo Achim,


    danke für dein Angebot was ich gerne annehme. Vielleicht verschafft mir das Flussdiagramm etwas mehr Klarheit. Mit dem Referenzhandbuch komme ich nämlich nicht so recht klar. Könntest du mir das Flussdiagramm bitte an die im Profil hinterlegte Adresse schicken.


    Vielen Dank!


    Freundliche Grüsse aus Köln
    Oliver

    Commander FW: 1.052 / DCC
    Spur HO Gleichstrom / Fleischmann PROFI-Gleis
    ROCO Multimaus
    Signal-, Schalt- und Weichendecoder von Digital-Bahn.de
    S88-Rückmeldebausteine von TAMS